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© Copyright 2022 Datamine Software 
All Rights Reserved 
Confidential and Proprietary 
 
Legal Disclaimer 
The product described in this documentation may be connected to, and/or communicate information and 
data via, a network interface, which should be connected to a secure network. It is your sole 
responsibility to ensure a secure connection to the network and to establish and maintain appropriate 
measures (such as but not limited to the installation of firewalls, application of authentication measures, 
encryption of data, installation of antivirus programs, etc.) to protect the product, the network, your 
systems, and the interface against any kind of security breach, unauthorised access, interference, 
intrusion, leakage, damage, or corruption or theft of data. We are not liable for damages or losses related 
to any such security breach, unauthorised access, interference, intrusion, leakage, damage, or corruption 
or theft of data. 
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MineScape 2021 
What's New 
The following section lists the new functionality and features delivered with MineScape 2021. 

 

Updated Start Page 
MineScape’s Start Page has been updated to provide users with an improved user experience and user 
interface. 

 

 

File Menu 

 

The File menu located on the left-hand side of the Start Page can be used to  open projects, create 
standard MineScape data files, edit user information, and configure settings for MineScape 2021. 
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Products and Apps 
Plugins within earlier versions of MineScape are now referred to as “apps” within MineScape 2021. Apps 
such as CAD (formerly Core), StratModel, GDB, are now grouped into the following four products: 

 

Geology 
The following apps are grouped under the Geology product: 

 

Surface Engineering 
The following apps are grouped under the Surface Engineering product: 

 

Underground Engineering 
The following apps are grouped under the Underground Engineering product: 

 

 

Engineering Optimization 
The following apps are grouped under the Engineering Optimization product: 

 

 



 Release Notes 

 

6 

Project Files 
MineScape projects can still be created and accessed through the Start Page. 
 

 
If required, projects listed under the Recent Projects can be removed to reduce the recent files listing. 
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Available Tools 

 

The Available Tools section of the Start Page can be used to access the following utilities: 

• License Manager 

• App Builder (MineScape SDK toolkit) 

• Table Editor 

• Module Monitor 

• Diagnostics 

• Spreadsheet Editor 

• Code Editor 

 

Warning for Expiring Licenses 
Warnings for an expiring license are now displayed through the Start Page and the bottom right corner 
of MineScape. 

 

New Ribbon System 
MineScape 2021 replaces the menus used in earlier versions of the product with ribbons. The new 
ribbon system has been designed to mimic user workflows and to provide access to new and existing 
more quickly. 

 

 
Home 

 

 
Design 

 
MineScape 2021 supports the ability to create custom ribbons and toolbars. 
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Extended Tooltips 
Extended tooltips are available for each option on MineScape 2021 ribbon. Position the mouse 
cursor over an option to display a description of the option, an associated hotkey (if one is 
available), and a Tell Me More link to the corresponding help topic. 
 

 
 

User Interface Enhancements 

Improved Forms and Updated Icons 

Numerous forms within MineScape 2021 have been updated to make use of the tree-control 
structure which provides both a streamlined workflow and a better user-experience. 
 

 
Where applicable, older icons within the interface have also been updated. 
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Form Spec Icons 
The icons displayed in the bottom left corner of all MineScape 2021 forms can be used to load and save 
form specs. 
 

 
 

New Popup Control for Display Definitions 
Display definition fields on MineScape 2021 forms now support the use of the ‘*’ wildcard to filter the 
contents of an available list. Display definitions can now also be created through a new popup dialog.  

Click the  button on an active form to display the new popup control. 
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Enter a name for the display definition through the available Name field and select an element colour, 

line style, line style width, marker type, and fill pattern. Click the  button to configure the size and 
angles for marker types and fill patterns. 

 

The right-click New, Edit, and View options can still be used to display the Display Definition form from 
previous versions of MineScape. 

 

Surface List Filtering 

The Filter ( ) icon on MineScape 2021 forms can be used to filter available surface definitions by type. 

Click the  icon to apply a surface type filter. 
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New Select All/Delete All Functionality 
Left-clicking in the top left corner of a form’s grid  will now select all available rows.  

 

Right-click on this area to display the new Delete All. The Delete All option can be used to delete all rows 
from the available grid. 
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Add Colours to Colour Palette 
MineScape 2021 supports the ability to add up to 50 colours to the standard CAD colour palette. To add 

colours to the colour palette, click the  icon on the Edit section of the Home ribbon and click Add 
Custom Colours. 

 

 

Colours can be selected from the standard colour palette or by using RGB, HSL, or CMYK values (via the 
Advanced button). MineScape needs to be restarted to apply the changes to the CAD colour palette. 
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New Interactive Filter Tab 

 

The new Interactive Filter tab within MineScape 2021 can be used to interactively filter loaded mesh 
files by their assigned metadata tags. Only mesh files with the matching metadata tags are displayed 
through the CAD window.  

Metadata tags can be assigned manually through the Mesh ribbon or automatically when generating 
engineering solids through the Open Cut app.  

 

Updates to the Properties Tab  
The layout of the Properties tab has been improved. Where possible, groupings have been updated and 
unnecessary fields removed, for example, statistical information for highlighted elements is now 
displayed through the Statistics tab. 
 
The Type field within the Properties tab can now be used to convert elements to a different element 
type. To convert a line, point, or polygon element, select the new type from the available list. 
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New Icon for Display and Render Order Tabs 

The Data View ( ) icon has been added to the Display and Render Order tabs. Click the  icon to list 
data through the Display and Render Order tabs without using a hierarchical tree. 

 
Display tab - Data View 

 

New Fields for Visual Overrides 
The Fade and Transparency fields under the Visual Overrides tab now include percentage fields.  
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Improved Reference Grouping for Triangle Prisms 
Loaded triangle prisms are now grouped under a single reference within the Display tab. 

 

 

Highlight Row in Element Details  
Placing the mouse cursor over a vertex within the CAD window will now highlight the applicable row 
within the Element Details form. 
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Improvements to Layer Copy and Move 
The Copy Layers and Move Layers forms have been updated and now allow up to 1000 layers to be 
move and copied between design files. 

 

 

 

New Scripts Toolbar 
A Scripts toolbar is included with MineScape 2021. The new default toolbar can be used to run an 
existing MPL script files (.ucs). Existing MPL script files can also be added to custom ribbons and toolbars. 

 

 

New Close All Icon 

The Clear All Stowed Forms ( ) icon has been added to the Stow ribbon. Clicking this icon will clear 
all entries from the Stowed list. 
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CAD Enhancements 

Rapid CAD Tools 
MineScape 2021’s new RapidCAD tools can be used to rapidly design, edit and manipulate in CAD 
without having to revisit a ribbon or toolbar. RapidCAD is collection of design tools that can be used to 
perform and complete your daily tasks more efficiently saving you countless hours of design work and 
everyday editing. 
 

 

 
 

https://minescapeonlinehelpqa.azurewebsites.net/8/en/Content/Images/Interface/RapidCAD_GreenArrow_Vertex_RightClick.png
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Metadata Support for Design Data 
Metadata tags can now be applied to elements within a design file layer. Once applied, the metadata tags 
can be used to select loaded elements directly from the CAD window.  

To apply metadata tags, the design file must use the “extended design file format”. The extended format 
can be set when creating a design file  or an existing design file can be upgraded using the Explorer tab’s 
new right-click Upgrade option. 

 

Design files using the extended format are represented by the  icon within the Explorer tab. The  
icon is used for design files that use the standard format. The design file format can also be displayed by 
positioning the mouse cursor over the design file name through the Explorer tab.   

Metadata tags and values can be assigned using: 

• the new RapidCAD right-click menu 
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• the Explorer and Display tab's new right-click Manage Metadata option 

 

• the options under Selection » Find Elements of the Home ribbon. 

 

The following options under Selection » Find Elements of the Home ribbon can be used to find and 
highlight elements by a metadata tag value. 
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If required, a design file using the extended format can be downgraded to the standard format using the 
Explorer tab's new  right-click Downgrade option. 

 

 

New ArcBall Rotation 
Intuitively rotate and manipulate objects in 3D space. Arcball Rotation within MineScape 2021 allows 
for quick and precise interrogation of your data.  
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Dynamic Corridor Slicing 
MineScape 2021 includes the ability to create dynamic slice corridors. within the current CAD window. 
The new Dynamic Corridor group of the Slicing ribbon can be used to create and manipulate slice 
corridors. 

 

 

 

New Interactive Curve and Smooth String Functionality 

 

The Interactive Curve option under the Element Utilities group of the Design ribbon can be used to 
interactively apply curve to a section of a nominated element. Unlike the standard Curve option, which 
uses defined  drawing parameters , the new Interactive Curve option uses control points to interactively 
apply the curve. 
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The Smooth String option under the Element Utilities group of the Design ribbon can  be used to smooth 
an existing line element without need to apply a sampling factor. The smooth string functionality 
available in earlier versions of MineScape has been renamed to Smooth Approximation. 

 

Improved Height Cue Colouring 
MineScape 2021 introduces improved height cue colouring functionality through the Visual Overrides 
tab. 
To apply height cue colouring, select the Height Cue check box before clicking the … button. 

 

Through the new Height Cue dialog, nominate a colour range and define the minimum and maximum 
elevation values for the data in the CAD window. Data outside of the nominated elevation range can also 
be assigned a specific colour. 
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Repair Data Options 
MineScape 2021’s new Repair Data options can be used to repair existing design data. The Repair Data 
options are available through the Element Utilities group of the Design ribbon. 

 

 

New Graphics Performance Setting 
Markers can now be hidden when a set number of elements have been selected. Select the new Hide 
markers when more than <n> selected elements check box to disable marker display when more than a 
set number of elements are highlighted through the CAD window. 

 

The Graphic Settings form is accessed through clicking the  icon from the Graphics group of the Home 
ribbon. 

 

 



 Release Notes 

 

24 

High-Performance Mesh Functionality 
MineScape 2021 introduces new high-performance mesh functionality to replace the triangle file format 
used in earlier versions of MineScape. Mesh files can be generated from external files, such as AutoCAD 
DXF/DWG files and LAS point cloud data, as well as from existing MineScape data, such as grid files and 
triangulations. Boolean operations, such as cut, merge, and union, and improved texture support is also 
available. 
 
Mesh functionality within MineScape 2021 is accessed through the new Mesh ribbon. 

 

The Mesh folder has also been added to the Definitions » Surfaces section of the Explorer tab. 

 

The Mesh folder supports the standard right-click options for creating, editing, viewing, and processing 
surfaces. 
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Engineering Enhancements 

Just in Time Modelling 
The Rapid Update group of the Open Cut ribbon can be used to easily maintain a short-term geological 
model, derived from the resource geologic model, based on new data collected in the field. 
 

 
 

Bench Blocks 
The Open Cut app’s bench blocks functionality provides short-term engineers with a rapid, interactive 
design tool while at the same time generating volume and reserves for rapid display in CAD. The bench 
blocks functionality within MineScape 2021 is accessed through the new Bench Blocks ribbon. 
 

 

 

Redesigned Engineering Solids 
Redesigned workflow for engineering solids creation. Improved visualization and filtering of the 
engineering solids for ease of validation and output.  
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StratModel Enhancements 

New StratModel Manager 
MineScape 2021 includes the StratModel Manager which can be used to create, edit, and view schema 
definitions. 

 

The Status node of StratModel Manager also lists the version of MineScape that was recently used to 
update the schema. 

 

StratModel Manager is accessed through the Schema » StratModel Manager section of the StratModel 
ribbon. 
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New Excel Templates for Reporting 
MineScape 2021 includes a collection of default Excel templates that can be used for reporting.  
These templates are stored under the Microsoft Office » Excel » Templates folder of the Explorer tab 

The following Predict options under the Drill Holes group  of the StratModel ribbon support output to 
Excel reports. 

 

The following Statistics options under the Drill Holes group of the StratModel ribbon support output to 
Excel reports. 

 

 

The following options under the Geological Model group of the StratModel ribbon support output to 
Excel reports. 

 

The following options under the Process Reserves group of the Reserves ribbon supports output to 
Microsoft Excel. 

 



 Release Notes 

 

28 

Import Drill Holes from CSV 
MineScape 2021 includes the ability to import drill hole data directly from existing CSV files .This new 
functionality can be used to easily import and load drill hole, downhole survey, and lithology data into 
MineScape. 

 

 

Washability Enhancements 
MineScape 2021 includes a dedicated ribbon to provide an improved Washability workflow and user 
experience. Where possible, existing forms have also been updated and improved. 
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SQL Server Support 
The GDB app, which is part of MineScape 2021’s Geology product, can now be used with a Microsoft 
SQL database. 

 

 

New Code Editor Utility 
The new Code Editor utility within MineScape 2021 can be used to view, edit, and run MPL script files 
(.ucs).  
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Data Transfer Enhancements 

Improved Exporting to AutoCAD DXF/DWG 
The new right-click Save As option can be used to export design file data to a nominated AutoCAD DXF 
or DWG file. Unlike previous versions of MineScape, the exported data can be located under different 
design files and layers. 

 

 

The Save As option can be accessed by: 

• right-clicking on highlighted elements within the CAD window 

• right-clicking on highlighted layers through  the Explorer tab 

• right-clicking on highlighted references through the Display tab 
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Batch Renaming and Mapping for Minex Grids 
When importing from an existing Minex file, grid values within the resulting MineScape grid file can now 
be explicitly renamed to separate between interval and quality values. 

 

The Explorer tab’s new right-click Mapping option can be used to automatically create intervals from an 
existing Minex grid file. To successfully generate the intervals, the chosen Minex grid file must contain a 
roof, floor, and thickness. 

To access the Mapping option, right-click on the Definitions » Surfaces » Interval folder. Once selected, 
the Interval Mapping form is displayed. 
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Plotting and Printing Enhancements 

Print Preview Functionality 
MineScape 2021’s new Print Preview utility can be used to print and preview PDF files from within your 
current working directory. The Print Preview utility can also be used to save a PDF file as an image file 
(.bmp,.gif, .jpg, .png, and .tif). 

 

Improved Table Container Behaviour 
Any text styles applied through an Excel spreadsheet, for example, text colour, bolding, or italics, are now 
applied to the contents of the table container when copying and pasting content from Microsoft Excel. 

 

Merge and View PDF Files 
The Merge PDF Files and View PDF check boxes have been added to the Output node of the Batch 
Plotting form. 
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Select the Merge PDF Files check box to merge the resulting PDF files into a single file. Select the View 
PDF check box to automatically display the resulting PDF plot(s) files through the Print Preview utility. 

 

New Default Plot Templates 
The  following default templates are now included with Plot Designer and can be used to create new plot 
files. 
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New Plotting Options 
The Force OneX line weight to 1px on PDF Zoom check box has been added to the Plotting Options 
section of the Plot Settings form. 

 

Select the Force OneX line weight to 1px on PDF Zoom check box to force the 'OneX' line style weight 
to be 1 pixel wide regardless of the zoom level in the resulting PDF file. 

  
Force OneX Line Weight Enabled 
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Force OneX Line Weight Disabled 

MineScape 2021 also provides the ability to compress PDF plot files produced through Plot Designer. 
Compressing PDF files allows you to reduce the overall file size of your resulting PDF plot files while 
maintaining image quality. 

These plot settings, which are listed under the Compression tab of the Plot Settings form,  are accessible 
through the Plot » Settings option under  the Plotting ribbon. 

 

 

New Storage Location for Hotkey Mappings 
Hotkey mappings for MineScape 2021 are saved to a file named ‘minescape.hotkey’ under your 
‘C:\Users\<user name>\AppData\Local\Datamine\MineScape\2021’ folder. Hotkey mappings in 
previous version of MineScape are stored in the ‘default.minescape’ file. 
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Spreadsheet Editor Updates 
Microsoft Excel files can now be exported to PDF directly through MineScape’s  Spreadsheet Editor 
utility. Use the Save As and Preview & Print options from the Spreadsheet ribbon to export an existing 
‘.xlsx’ file. 

 

Text and fill colours can now also be applied to cells within the Spreadsheet Editor utility. 
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Defects 
This section lists all bug fixes and corrections delivered through MineScape 2021. 

 

#23725 : Seams incorrectly modelling through boreholes when they should be pinched out 

#24765 : Verticality data erased once drill hole edited through StratModel’s correlation tool 

#25536 : Changes in 2D graphics validation issues not flag as warnings in GDB 

#25793 : GDB relating table column to sedimentary lithotype column 

#28137 : Unable to run the batch file from reserve functionality 

#28491 : Table postings results differ from resource classification postings 

#29217 : Filter vertex option not working 

#29325 : Display issues with shapefiles in MineScape 

#29674 : Product loading license bug 

#29754 : Fatal error when updating GDB sizing table 

#30015 : Unable to perform selection and panning in CAD 

#30041 : Unable to import drill hole data from a CSV file 

#30237: Unable to display JPG images registered in an earlier version of MineScape 

#30445:  License incorrectly treated as being borrowed from server 

#30469 : Multiple errors in GDB 

#30482 : MineScape crashes when loading form spec 

#30485 : MineScape crashes when wifi/network connection is down 

#30486 : MineScape crashes when wifi/network connection is down 

#30488 : MineScape crashes when loading form spec 

#30489 : MineScape crashes when wifi/network connection is down 

#30491 : MineScape crashes when wifi/network connection is down 

#30507 : MineScape crashes after editing element colour 

#30509 : MineScape crashes when trying to dock Module Monitor tab 

#30519 : MineScape crashes when trying to update temporary graphics 

#30521 : MineScape crashes when project is changed and ‘Pick element’ prompt is active 

#30522 : MineScape crashes when loading form spec 

#30524 : MineScape crashes when wifi/network connection is down 

#30531 : MineScape crashes after editing element colour 

#30570 : Miscellaneous texture and Geotiff issues 

#30572 : Module error when running StratModel contour 

#30596 : MineScape crashes after editing element colour 

#30808 : MineScape crashes when wifi/network connection is down 

#31190 : Line weight and marker issues in text element space when generating PDF through Plot 
Designer 
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#31396 : Polygon centroid results are different across MineScape 

#31440 : Triangle prism is not clipped to topo surface 

#31442 : Annotation to text output characters and orientation 

#31538 : Element markers in lines, polygons, and text. Incorrect viewport count message. Text and lines 
overlap in PDF 

#31681 : Temporary files left after processing table file graphics 

 



 Release Notes 

 

40 
 

MineScape 2021 Update 1 
The following section lists the new functionality, features and defect corrections delivered with 
MineScape 2021 Update 1. 

 

What’s New 

RapidCAD Performance Improvements 
Improved performance when editing elements while the Properties Editor is displayed. 

 

Start Page Enhancements 
Improved the loading of components for the MineScape Start Page. A status message is now also 
displayed when project thumbnails are being retrieved. 

 

Rapid Reserver Rebrand 
The Open Cut app’s Rapid Reserver ribbon has been renamed to Bench Blocks. 

 
 

New Mesh Enhancements 
Mesh functionality has been improved to now allow the importing of up to 100,000 files at one time. 
Multiple files can now be combined into a single file when using the Multiple Files option on the Mesh 
Import form. 
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Clearing the Generate Individual Files check box while using the Multiple Files option will now produce 
a single multi-mesh file using all supported import files found under the nominated folder. Select the 
Generate Individual Files check box to create an individual mesh file for each import file found under the 
nominated folder. 

The Surface Mesh » Create Surface option now supports the use of multiple boundary polygons when 
creating mesh surfaces within MineScape 2021. The Draw Polygons check box has also been added to 
the Create Surface form. 

 

Select the Draw Polygons check box to pick the required boundary polygons directly from the CAD 
window. Clear the Draw Polygons check box to interactively draw the boundary polygons within the 
CAD window after completing the Create Surface form. 

In the following example, the required boundary polygons (highlighted in green) have been selected 
directly from the CAD window. 
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The Validate & Repair option has been moved from the Edit group  to the File group of the Mesh ribbon. 

 

New Graphics Settings 

 

The Show Vertices When Drawing Element check box has been added to the RapidCAD node of the 
Graphics Settings form. The Show Vertices When Drawing Element check box can be used to display 
the vertices for new elements as they are being created within the CAD window. Vertices within the new 
element are displayed as grey dots. 
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The Show Vertices for Nearby Elements When Drawing check box has been added to the RapidCAD 
node of the Graphics Settings form. The Show Vertices for Nearby Elements When Drawing check box 
can be used to display the vertices for nearby elements when creating an element within the CAD 
window. Vertices within a nearby element are displayed as grey dots. If multiple elements are near the 
mouse cursor, press the N key to cycle through the elements. 

 

The  Show Vertices When Drawing Element and Show Vertices for Nearby Elements When Drawing 
check boxes are selected by default after installing MineScape 2021 Update 1.  

 

New Help Navigation Icons 
Navigation and print icons are now displayed at the top of each help topic. 

 

Click the  and  icons to go backwards and forwards through your help browsing history for the 

current MineScape session. Click the  icon to print the current help topic. 

• Offline Help  - A new MineScape 2021 offline help installation is required to access the updated 
hep files for MineScape 2021 Update 1. A new copy of the MineScape 2021 offline help installer 
has been uploaded to the MineScape software distribution portal. An existing MineScape 2021 
help installation must be removed prior to installing the updated MineScape 2021 help.  

• Online Help - Content stored on the official MineScape help server is updated automatically to 
reflect the changes introduced through MineScape 2021 Update 1. 
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Defects 

#30023 – Split button tooltips and flashing custom toolbar 

Problem: Incorrect tooltip for split buttons on custom toolbar. Flashing custom toolbar from other 
document types. 

#31612 – Unable to select element near the viewport border 

Problem: Unable to select an element that is positioned near the viewport border. 

#31710 - Error validation for Remove Spike and Remove Embayed 
Sections forms 

Problem: A generic data box that allowed non-numeric values was used for the displayed forms. 

#31819 - Selecting a mesh requires two mouse clicks 

Problem: The action was using AskID when selecting mesh files. By default, AskID behaviour requires a 
double-click of the mouse. 

# 31963 – Save confirmation  prompt 

Problem: Confirmation prompt incorrectly displayed after exiting the Spreadsheet Editor utility without 
making any changes. 

#31965 - Unable to update bulk element using Properties Editor 

Problem: The property editor controls were set to use current values from the ribbon, and it doesn't 
reflect the attributes of the selected elements. 

#32054 - Able to create two dynamic corridors 

Problem: Action called twice (overlapping). Each action creates temporary graphics which makes two 
corridors appear in the CAD window. 

#32069 - Unable to create mesh relimit 

Problem: The original mesh is already unloaded so the function fails when Apply is pressed a second 
time. 

#32348 - Synching issue with icon 

Problem: Synching issue with the Axes On/Off icon when opening a project using a session file that 
contained a CAD window. 

#32395 – Mesh file name displayed in lowercase 

Problem: Mesh name incorrectly displayed in lowercase after copying the mesh file. 

#32472 - Data grid display issue after resizing form 

Problem: Data grid does not expand after resizing the active form. 

#32514 - Suffix not added to mesh names 

Problem: Suffix not added to mesh names through Boolean » Intersect, Union, and Difference. Suffix 
field in the form should only visible when the boolean operation allows multi-mesh output.  
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#32578 - Plot Designer north arrow rotates in 3D when  using arcball 
rotation setting 

Problem: A flaw in north arrow's transform code calculated  the rotation based on the current matrix. 

#32173 – Display issue with StratModel Manager 

Problem: Column sizing and display issues when using the horizontal scrollbar and dragging it to the far 
right. 

32571 - Unexpected error when checking surfaces 

Problem: An unexpected error occurs when checking surfaces. 

#32579 – Mesh incorrectly coloured in resulting plot 

Problem: White coloured mesh displayed as black in resulting plot. 

#32582 – Graphical changes incorrectly committed 

Problem: Graphic changes committed by the Table Editor utility even when errors are present. 

#32622 – Save and restore formspec not mapping correctly 

Problem: Save and restore formspec not mapping correctly for washability CSV import. 

#32664 – MineScape crashes when deleting sequence data 

Problem: MineScape crashes after using the Delete All function to delete all sequence data. 

#32768 – Check desurvey fails when using specific data 

Problem: Check desurvey fails when using specific data. 

#32835 - Error when saving washability table 

Problem: Error when saving an edited washability table. 

#32905 – Element name not updated 

Problem: Upgrading a design file with multiple layers does not update the Element Name attribute. 

#32912 – Error with insert correlate 

Process: The Validate check box causes errors when the correlate insert process has not been 
committed. 

#32926 – Unable to create log plot file 

Problem: Unable to create log plot file. 

#32952 – MineScape crashes when saving an Excel file 

Problem: The Spreadsheet Editor utility crashes when trying to save an Excel file that is already open 
through an external application. 

#32953 – Compound not listed through StratModel Manager 

Problem: Compound is not listed through the Interval field of StratModel Manager. 
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#32954 – Custom colour still available 

Problem: Custom colour still listed even after it has been removed. 

#32956 Unable to update values 

Problem: Unable to update values when auditing is enabled. 

#32958 – Conflicting behaviour when pressing Space key 

Problem: Conflicting behaviour when pressing the Space key to toggle tooltip display. The Space key was 
being used by both Show/Hide Corridor (on the Slicing ribbon) and Toggle Tooltip (on the Bench Blocks 
ribbon). 

#32965 -  Extend to Boundary not working 

Problem: RapidCAD ‘s Extend to Boundary option not working as expected. 

#32967 – COGO manager does not disappear after drawing 

Problem: COGO manager does not disappear after completing a drawing operation. 

#32976 - Status prompt unclear  

Problem: The status prompt for the Surface Mesh »  Relimit option is unclear. Prompt now displays "Pick 
a polygon, Q to quit". 

#32977 – RapidCAD icon appears twice 

Problem: RapidCAD’s  green icon appears twice after quickly right-clicking on the purple dot icon. 

#32979 – Tooltip issue for triangle prisms 

Problem: Tooltip descriptions are empty for triangle prisms. 

#32984 – Data grid display issue after resizing form 

Problem: Data grid does not expand after resizing the active form. 

#32990 – Reserves report not producing output Excel file 

Problem: Unable to generate a reserves report through Excel when the TEMP variable has been set to a 
custom folder. 

#32991 – Error shown when solid creation is not completed in correct 
order 

Problem: A generic error message is displayed when engineering solid creation is not completed in the 
correct order. 

#33005 – MineScape crashes when refreshing viewport 

Problem: MineScape crashes when refreshing viewport. 

#33006 – MineScape crashes when clearing annotations 

Problem: MineScape crashes when trying to clear annotations. 
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#33045 Module crashes when validating strip line for engineering solids 

Problem: SERVMESH module crashes when validating strip lines for engineering solid. 

#33048 - Unable to open Plotspec file 

Problem: Plotspec with multiple features within one slot not supported. When converting plotspec to 
plot design, some viewport locations were incorrect.  

#33056 – Options not applied to StratModel contours 

Problem: The Filled, Lines , and Use Colour Palette options not implemented for the ‘Expression, 
‘Quality’, ‘Multi Model’, and ‘Multi Quality’ data source types. 

#33057 – Metadata deletion issue 

Problem: Metadata for other elements incorrectly updated after deleting a metadata key from a layer.  

#33075 – Continue Element not working 

Problem: RapidCAD’s Continue Element not working as expected. Intermittent issue where holding the 
left mouse button didn’t trigger the function. 

#33076 - First vertex automatically added when creating a line 

Problem: The first vertex is automatically added when creating a line using RapidCAD. The last detected 
point is incorrectly being used instead of the user input. 

#33099 – Mesh file name displayed in lowercase 

Problem: Mesh name incorrectly displayed in lowercase after renaming the mesh file. 

#33122 - Viewport information not listed through Properties Editor 

Problem: Properties for the active viewport are not updated through the Properties Editor.  

#33123 – Viewport value missing after switching between apps 

Problem: The Viewport value under the Display tab is empty after switching between CAD and Plot 
Designer. 

#33134 – Unable to access RapidCAD options 

Problem: Unable to access options via the green arrow icon after using RapidCAD’s Continue Element. 

#33137 – Active node for StratModel Manager 

Problem: The Model node is incorrectly set as the active node after building the table or grid through 
StratModel Manager. 

#33141 - SQL Server password policy issue 

Problem: SQL Server honours the Microsoft Windows password policy by default, meaning the default 
GDB login password ("gdb") is rejected on some PCs 

#33178 – MineScape crashes when creating a mesh file 

Problem:  MineScape crashes due to an unhandled attribute value within the Vulcan import file.  
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#33179 - Properties Editor does not update 

Problem: The Properties Editor does not update while the Edit Annotation form is displayed. 

#33176 – Incorrect triangle output when using offset values 

Problem: Incorrect triangle output when using offset values. Missing links in the wireframe created 
through Utilities » Drives. 

#33251 – Invalid output produced through Merge DTM 

Problem: Invalid output produced through Merge DTM. 

#33254 - 2D Graphics not displaying correlation and error message 

Problems:  2D graphic not displaying correlation: In some cases,  the DEDERIVE or NOHOLESELECT 
error is displayed. Graphics occasionally not drawn properly, for example, no correlation or no intervals. 
If grid value is set, but the display definition is empty, SERVORAMPL will display the ”Converting string 
yellow to an integer. Invalid character """ in name " error message. 

#33255 – Commit does not commit the changes 

Problem: Unable to commit graphical changes. 

#33265 -Large coordinates warning 

Problem: Large coordinates warning is displayed when performing a CAD operation. 

#33286 - StratModel Cross Section Form Issue 

Problem: Right-click Row » Fill Down and Pick options are not updating the selected control as expected. 
After reopening the form, fields are also not populated by the proper formspec values from the previous 
instance. 

#33320 – Reset/Replace empty interval 

Problem: Interval not listed in the interval list. Reset/replace to empty interval displays the "X152: 
Interval not in the interval list" error message. 

#33321 - Properties Editor doesn’t retain values after zooming or 
panning 

Problem: When multiple elements are selected, zooming, or panning  in the viewport incorrectly replaces 
the selection set properties with the viewport properties. 

#33326 - Create solid issue when using specific data 

Problem: Issue in the projection result,  the tag definition on the projected boundary is different from the 
original polygon. 

#33350 – Error message about an incorrect password, but database 
creation continues 

Problem: The GDB password not sent correctly causing an error message regarding an incorrect 
password. Database is created despite error message. 

#33353 – Unable to list database names 

Problem: Unable to list database names when using a non-admin user. 
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#33359 - Clear option missing for the Attribute Display Definition form 

Problem: The Clear right-click menu option is missing for the Text Display Definition field on the 
Attribute Display Definition form. 

#33376 – Unable to delete user role 

Problem: Unable to delete a user role via the Delete button when using an SQL database. 

#33384 – North arrow container aspect ratio and scale not working 

Problem : The Keep Aspect Ratio and Image Scale options for north arrow containers not working as 
expected. 

#33387 – Synch issue with check box state 

Problem: Group check box not responsive after  the resulting mesh was recalculated. 

#33398 – MineScape crashes after removing custom colours 

Problem: MineScape crashes after removing custom colours. 

#33410 – Performance issue when deleting large number of mesh files 

Problem: MineScape slow to respond after deleting 300+ mesh files. 

#33417 – Incorrect mesh output 

Problem: Incorrect mesh output when using the Delete Outside option with boundary polygons that 
intersect. 

#33419 – Unable to import mesh data from GoCAD Triangulated Surface 
files 

Problem: Unable to import mesh data from GoCAD Triangulated Surface files 

#33425 - Warning message displayed when importing DXF/DWG files 

Problem: A warning message is displayed when creating a mesh file from a DXF/DWG file. 

#33433 – Incorrect mesh output after dragging and dropping images 

Problem: Incorrect mesh output produced after dragging and dropping image files into the CAD window. 

#33435-  Unable to locate input files when importing Datamine files 

Problem: Unable to locate input files when creating a mesh file from Datamine files. 

#33438 – Mesh output incorrect 

Problem: Incorrect mesh output produced when using Create From Surface. 

#33442 – Incorrect total values in reserve report 

Problem: Incorrect subtotal and total average values in resulting StratModel reserve report. 

#33444 – New mesh files not listed in alphabetical order 

Problem: New mesh files are not listed in alphabetical order after being created. 
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#33448 – Mesh file not automatically displayed after import 

Problem: Imported mesh files are not automatically displayed when using the Display After Import check 
box. 

#33461 – Database connection name incorrect 

Problem: Database name being used instead of connection name. 

#33463 – MPL scripts not working 

Problem: Unable to successfully run MPL scripts that use the FENCERECTANGLE verb. Script files work 
in an earlier version of MineScape. 
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MineScape 2021 Update 2 
The following section lists the new functionality, features and defect corrections delivered with 
MineScape 2021 Update 2. 
 

What’s New 

CAD 

Start Page Enhancements 
The selection icons and buttons on the Start Page are now always displayed. 

 
The News section has been added to the Start Page. The News section can be used to access MineScape 
Insider News articles. The News section can also be accessed through the File menu and via the new icon 
on the Quick Access toolbar. 
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Improved CAD Forms 
The appearance and layout of numerous forms have been upgraded and improved to provide a 
better  user experience. 

 

An Apply button has been added to the Create New Layer form. 

 

Explorer Tab Enhancements 
The Explorer tab's right-click Import and Export options have been removed. These option were 
displayed after right-clicking on a design file. The right-click Import option, which was displayed after 
right-clicking on a layer, has been renamed to Transfer Data. 
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Display Tab Enhancements 
View filtering options for the Display tab are now available through a list.  

 

Layers listed through the Display tab can now also be saved and loaded from a display list file using the 

new  and  icons.  

 

Click the  icon to save the current list of loaded layers to a display list file (.lst). Display list files are 
stored under the displaydock folder of the current project. Click the  icon to load a previously 
displayed list of layers from a display list file (.lst). Visual overrides applied when a list of loaded layers is 
saved are retained when the display list file is loaded. 
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RapidCAD Enhancements 
The Delta XYZ option has been added to  RapidCAD’s Quick Input Box list. The Delta XYZ can be used 
to determine specific delta X, Y, or Z distance values from the previous point to a nominated point or line 
segment. 

 

A custom Z value can now be applied when inserting vertices through the RapidCAD tool. 

 

Warning for Hidden Write Layer 
A warning message is now displayed through the Feedback tab when attempting to create an element 
within the current write design layer that has been hidden from view. 
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New Cubic Spline Tool 
The Cubic Spline option has been added to the Draw group of the Home ribbon. The Draw Cubic 
Spline icon has also been added to the Design toolbar. 

 

 

The Cubic Spline option can be used to create a smoothed curve that passes through a set of predefined 
points within the CAD window. A single curved line can contain up to 4,094 points. The element is 
assigned the 'LINES' object class and created using the default attributes. 
In the following example, the green element represents the position of the predefined points with the 
yellow element representing the resulting smooth curved line. 

 

Copy and Paste Enhancements 
The Clipboard » Copy and Paste options on the Home ribbon now support the ability to copy and paste 
on drill hole, poly3D, and fault objects. 
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Bird’s-Eye Window Enhancements 
The Birds-Eye option on the View and Slicing ribbons is now a toggle option that can be used to hide and 
display a bird’s-eye window for the current on CAD Window.  

 

 

Placement options are also available underneath the Birds-Eye option. 

 

New Remove Option for Dynamic Slicing 
The Remove option has been added to the Dynamic Slicing group of the Slicing ribbon. 
The Remove option can be used to remove a loaded slice plane from the CAD window. Select the slice 
plane to remove from the displayed list or select Remove All to remove all loaded slice planes. 
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New Height Cue Colour Palette 
The 'Pastel2 Colours' entry added to the Height Cue dialog. The Height Cue dialog is displayed when 
applying height cue colouring through the Visual Overrides tab. 

 

Mesh Enhancements 
The Create Surface Definition check box has been added to the MineScape Triangulation node of the 
Mesh Export form. Select the Create Surface Definition check box to create a triangle surface definition 
when exporting a mesh file to the legacy triangulation format. The resulting surface definition is named 
after the output triangulation file. 
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A prompt whether to create a surface definition is also displayed when using the Explorer tab’s right-
click Convert To » Triangulation option. Surfaces are listed under the Definitions » Surfaces folder of the 
Explorer tab. 

  

The Surface Mesh » Expand option on the Mesh ribbon can now expand or shrink an existing mesh file by 
a nominated distance. Enter a positive value to expand an existing surface mesh, and a negative value to 
shrink the surface mesh.  

 

In the following example, the original mesh file along with the expanded and shrunken mesh files are 
displayed. The original mesh file is coloured red while the expanded mesh is coloured blue and the 
shrunken mesh yellow. 
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The Surface Mesh » Register option on the Mesh ribbon now displays a confirmation prompt after 
selecting the elements to register from the CAD window Select Edit Existing to update the Z-values of 
the nominated elements. Select Create New to create new elements within the current write layer. 

 

Data Exchange Enhancements 

 

The  Data Exchange » Import option now displays the Import Design Data form. The Import Design 
Data form can be used to import data from an external source into a MineScape design file. 
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The Data Exchange » Export option now displays the Export Design Data form. The Export Design 
Data form can be used to export data from a MineScape design file to an external file. 

 

Custom Ribbon Enhancements 
The Explode to My Ribbon option has been added to the right-click customisation options. Some ribbons 
within MineScape contain a list of parent and child options that are accessible after clicking on the arrow 
control under the parent option name. An example of this functionality is the Convert group of 
the Design ribbon which contains two parent options(To Polygons and Explode Text) with nested child 
options. 
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In previous versions, right-clicking on the To Polygons option and selecting Add Option to My Ribbon would 
result in the To Polygons option and all options underneath it (To Lines, To Points, To Object Definition, 
and Sheet Spec to Layer)  being added to the custom ribbon as shown below. 

 

Expanding the list and right-clicking on child option before selecting Add Option to My Ribbon would add that 
specific option to the custom ribbon. In the following example, the Add Option to My Ribbon option was 
accessed by right-clicking on the To Points option. 

 

The new Explode to My Ribbon option can be used to add the contents of a nominated parent-child list as 
separate options within the custom ribbon. In the following example, right-clicking on the To Polygons option 
and selecting Explode to My Ribbon would result in all options in the To Polygons list being added to the 
custom ribbon as separate options. 

 

Multiple custom ribbons and toolbars can now be deleted through the Customise from. Press and hold 
the Shift or Ctrl key while left-clicking to select multiple entries before pressing the Delete button. 



 Release Notes 

 

62 
 

Plot Designer Enhancements 

The Plot Designer app now supports the ability to define and use custom plotting variables. Plotting variables 
are now also grouped into two categories - local and global.  

 

 

A local variable refers to plotting variables that are only available to a single plot design file or template, 
whereas a global variable is available to all plot design files and templates within the current project. Local 
plotting variables are defined through the Variables » Local option and global variables 
through Variables » Global. 
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Table Editor Enhancements 

The Import and Export options have been added to the Table Editor ribbon. 

 

Select the Import option to import the contents of a nominated Datamine Studio RM database into a 
MineScape table file. Select the Export option to export the contents of a MineScape table file to Datamine. 
The import and export functionality originally under the Data Exchange » Import and Export options of the 
Home ribbon. 

 

Geology 

StratModel Enhancements 

The Inclined Model and Hole Adjustment Settings section has been added to the Table node of StratModel 
Manage. This new section now allows StratModel to support resource seams that are  heavily inclined with 
non-vertical drill holes. 
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The Draw Schema button added to StratModel Manager. Click the Draw Schema button to draw the current 
stratigraphic schema to a nominated design file layer. 

  

The Ignore Lines Both Lithology and Unit Are Empty  check box has been added to the Import Drill Holes form. 
Select this check box to ignore lines within the input file that have no associated interval and lithology values, 
i.e., values are blank or missing. Clearing this check box will result in blank 'Not logged' records being created 
within the drill holes for each line that has no associated interval and lithology values. 

 

The Import Drill Holes form is displayed after selecting Data Exchange » Import  » Drill Holes from ASCII from 
the StratModel ribbon. 
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The Drill Holes Lithology option has been added to the Data Exchange » Import  group of the StratModel 
ribbon.  

 
The Drill Holes Lithology option can be used to update the lithology values for existing drill holes that already 
have intervals. The lithology values are imported from a nominated ASCII file and merged into the existing drill 
hole objects that have missing lithology logs. 
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The View Table has been added to the Build node of the Washtable & Import form. Click the View Table 
button to view the resulting wash table file once it has been created. 

 
The Washtable & Import form is displayed after selecting Create » Washtable & Import from the Washability 
ribbon. 
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Surface Engineering 

Bench Blocks Enhancements 

A stratigraphic schema AND model type can now be selected when using the Use Surfaces option to create the 
base of the bench solid. When using a Schema, only the surfaces defined within the chosen schema are listed 
through the Surface Name list. If a Schema is not selected, the Surface Name list will contain all surfaces for 
the current project. 

 

The Create Bench form is displayed after selecting Create from the Bench Blocks ribbon. 

 

The Merge DTM option on the Bench Blocks ribbon has been renamed to Bench Blocks to DTM. 
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Dragline Enhancements 

The 1 through 6 keys along the top row of the keyboard are now used to run Dragline-specific commands 
instead of quickly switching between available apps. A notification message is displayed through 
the Feedback tab when the Dragline app is active. 

 

 

UG Engineering 

UG Survey Enhancements 

The UG Survey app now supports the use of  Microsoft SQL Server databases. 

The appearance and layout of numerous forms have been upgraded and improved to provide a 
better  user experience. 
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The Setup » Run and Setup » Admin » Survey Login options on the UG Survey ribbon now support database 
from all ODBC data sources. 

 

The New Database option has been added to the UG Survey ribbon. Select the New Database option to create 
new UG Survey database. Databases can now be created without having to load the GDB app when wanting to 
use  Microsoft SQL Server. 
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The Survey Login and  Survey Logout option have  been added to the UG Survey ribbon. The Survey Login 
option can be used to connect to an existing database, while the Survey Logout option can be used to 
disconnect from the current database. 

  

The Add Survey Schema to Existing Database option has been added to  the  UG Survey ribbon. The Add 
Survey Schema to Existing Database option can be used to connect to an existing database. 
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The Attributes option on the UG Survey ribbon has been renamed to Graphical Attributes. 
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Defects 

#25582 - Unable to open shape file 
Problem : Unable to open shape files listed under the MINSITE folder. The "Shape file {name} incomplete. 
Ensure that {name}.shp, {name.}.shx, and {name}.dbf are available." error message is displayed. 

#25994 - Viewport borders missing from Plot Designer 
Problem - Viewport borders are missing after sending content from CAD window to Plot Designer. Issue occurs 
when the CAD window contains multiple viewports. 

#30797 –Section graphics issues 
Problem : Overlapping header in output GDB section graphics. 2D graphics header is also not aligned correctly. 

#31845 - Code Editor not saved to session file 
Problem : The Code Editor tab is not loaded correctly after reloading a project from a session file. The last open 
document should be displayed. 

#32149 - Table mappings reset after changing preview size 
Problem : Table mappings for Washability's Import CSV form resets after changing the Preview Size value. 

#32207 – “Invalid Field” warning message displayed 
Problem : The “Invalid Field” warning message is displayed. This issue only occurs when using a long file or 
folder path. 

#32580 - Selected container ignored when using Link option 
Problem : Currently selected container is ignored when using the Link option. 

#32588 - Cannot display 2D graphics 
Problem : Cannot displayed 2D graphics through GDB when using specific data. 

#32603 - Fatal errors issued when all validation set to warning 
Problem : Fatal errors are issued when all validation settings are set to 'Warning'.  

#32955 – Incorrect option label 
Problem :  Incorrect option label displayed through right-click history menu. 

#32957 - Form resize issue 
Problem : Form incorrectly resized and is too large. 

#32978 - Duplicate mesh folder under Bench Blocks scenario 
Problem : Duplicate Mesh folder displayed under the Bench Blocks scenario after restarting the project. 

#32985 - Error when creating table 
Problem: Error when creating a table through the Modify Schema form. 

#33133 - Mesh file deleted after renaming 
Problem : Mesh file is deleted after renaming the file. Issue only occurs when the file is renamed to use the 
name of another existing mesh file. 

#33146 - Unable to run option from Where's Is My Option? form 
Problem : Unable to run Import Drill Holes from ASCII option from the Where's My Option? form. 

#33322 – Cannot import database roles 
Problem : Unable to correctly import database roles from SQL server backup file. 

#33404 – MineScape crashes 
Problem : MineScape crashes when the same value is assigned to the Name and Group metadata tags for a 
mesh file. This issue only occurs while the mesh file was selected through the Properties tab. 
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#33422 – Multiple tabs highlighted 
Problem : Multiple tabs highlighted after rearranging CAD windows. 

#33424 - Unable to search mesh folder 
Problem : The Explorer tab's search functionality is not available to the Mesh folder. 

#33487 - Extra column displayed 
Problem : An extra column is displayed at the end of the data grid for some forms. 

#33497 – Wrong file opened after import 
Problem : The wrong mesh file is displayed after completing import. 

#33494 - Mesh file incorrectly deleted 
Problem : Mesh file is incorrectly deleted when both the Generate Individual Files and Overwrite check boxes 
have been selected. 

#33500 - Form resize issue 
Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33504 - Surface repair option fails  
Problem : Incorrect output produced when using Surface Mesh » Fill Holes. 

#33505 - Textures broken when applied to multi-mesh output 
Problem : Textures broken when applied to multi-mesh output. 

#33525 - Form does not retain values 
Problem : Previously entered values are not retained after reopening the form. 

#33526 - Error when using a boundary polygon with many vertices 
Problem : Solid Mesh »  Between Surfaces produces an error when using a boundary polygon with many 
vertices (1,000+). 

#33552 - Restoring formspec displays incorrect fields 
Problem : Incorrect fields display after restoring a formspec for a form that uses a tree-control layout. 

#33576 - Expanded mesh does not follow input mesh 
Problem : The Z level of the expanded mesh file does not follow the input mesh. 

#33599 - Empty error message 
Problem : An empty error message is displayed when attempting to run reserves using a solid mesh that is 
currently open. 

#33615 - Mesh data not loaded from saved plot 
Problem: Mesh data not loaded after loading plot designer file. 

#33681 - Delete key incorrectly deletes element 
Problem : Element incorrectly deleted after pressing the Delete while using RapidCAD to delete vertices. Issue 
occurs after quickly  moving from one vertex to another. 

#33731 - Unable to use an existing base point 
Problem : Unable to select an existing base points using Base Points » Delete. 

#33752 - Duplicate element created 
Problem: A duplicate element is created after using Highwall Ramps » Tag Segments or Manage Strips » 
Rename. 

#33777 - RapidCAD extend/reduce line not working in rotated view 
Problem : RapidCAD's extend/reduce line functionality does not work as expected when using a specific 
rotation or view. 
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#33816 - Form resize issue 
Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33819 - Form resize issue 
Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33854 - Drop-down field changes to an input field after clearing formspec 
Problem : Drop-down field for Washability » Import changes to an input field after clearing formspec. 

#33868 - Form resize issue 
Problem : Form incorrectly resized and is too large after moving form to a different monitor. 

#33924 - Cannot enable/disable intervals and surface lists 
Problem : Cannot enable or disable the intervals and surface lists on Geological Model » Cross Section when 
All Intervals or All Surfaces selected. 

#33934 - Form issues 
Problem : Unable to view measure name through Orthogonal Measure » Edit or View. Two Left fields 
displayed under the Measurements tab.  

#33947 - Overlapping popups on Start Page 
Problem : Overlapping popups on Start Page. Popup menu does not close after closing dialog window. 

#33957 - Error message displayed when creating a basepoint 
Problem : The "New point {x} already exists" error message is displayed when creating a basepoint containing 
an underscore character (_) in its name. 

#33958 - Unable to run Resgraphics 
Problem : Unable to run Graphics » Reserve Graphics without UCB file in MINSITE folder. 

#33976 – Unable to find batter block 
Problem : Unable to find batter block when using Graphics » Reserve Graphics. 

#33983 - Form resize issue 
Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33991 - Menus missing from Spreadsheet Editor ribbon 
Problem : Menus are missing from the Spreadsheet Editor ribbon. This issue only occurs after opening a 
spreadsheet that uses a font different from MineScape. 

#33998 - MineScape crashes when using invalid project root path 
Problem : MineScape crashes when an invalid project root path. 

#34000 - Only able to nominate one copy direction 
Problem : Only able to nominate one direction when using Copy » Parallel. 

#34037 - Form fields truncated  
Problem : Field names on some GDB forms are truncated. 

#34045 - Form fields truncated 
Problem : Field names on the Just In-Time DTM form are truncated. 

#34060 - Form is truncated 
Problem : The Load Formspec form is truncated after the Advanced option is expanded. 

#34077 - Values missing from closure report 
Problem : Values, such as final back, final stand, and date, are missing from the report produced through 
Measure » Close. 
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#34080 - Empty error message when running reserves 
Problem : An empty error message is displayed when running reserves. 

#34090 - Mouse cursor position used instead of tentative point location 
Problem : Current mouse cursor position is used instead of tentative point location. This issue only occurs when 
RapidCAD's input dialog has been locked. 

#34127 - Error when running reserves 
Problem : An exception error is displayed when attempting to run reserves with multiple meshes. 

#34135 - Unable to delete trend surface 
Problem : Unable to delete trend surfaces through the Conformable node of StratModel Manager. 

#34138 -Report truncated 
Problem : The resulting drill hole statistics report is truncated. 

#34167 - Mesh attributes ignored 
Problem : Mesh attributes, such as colour, transparency, and texture, are ignored and not applied to the output 
mesh. 

#34169 - Form is truncated 
Problem : The mesh colour selection dialog is truncated. 
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#34175 - MineScape crashes 
Problem : MineScape crashes after clicking on a reference through the Display tab. Issue only occurs after 
applying a visual override. 

#34228 – Custom toolbar disappears 
Problem : Custom toolbar disappears after switching between available apps. 

#34232 - MineScape crashes 
Problem : MineScape crashes when trying to define a new coal template spec for a new database project. 

#34233 – Unable to convert polygon 
Problem : Unable to convert a design polygon to a normal polygon using Convert » To Polygons. 

#34238 – Extra column displayed 
Problem : An extra column is displayed at the end of the data grid for some UG Survey forms. 

#34281 – MineScape crashes 
Problem : MineScape crashes when using the Import Leica form through UG Survey. 

#34286 – MineScape crashes 
Problem : MineScape crashes after adding a drop-down icon to a custom ribbon. 

#34299 - Form is truncated 
Problem : A number of GDB forms are truncated. 

#34328 – Incorrect option label 
Problem : Incorrect option label displayed through right-click history menu. 

#34329 – Unable to edit base point 
Problem : Unable to edit base point when surveyor set to ‘None’. 

#34332 – Long delay when editing elements colour 

Problem : Long delay when editing an element’s colour through the Properties Editor. 

#34348 – Vertices not shown in some cases 

Problem : Gray vertices are not shown when the mouse 
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MineScape 2021 Update 3 
The following section lists the new functionality, features and defect corrections delivered with 
MineScape 2021 Update 3. 
 

What’s New 

CAD 

Improved CAD Forms 
The appearance and layout of numerous forms have been upgraded and improved to provide a better 
user experience. 

 

 

Data Transfer Enhancements 
Design file and mesh file data displayed through the CAD and Paper Window can now be exported to a 
LandXML file. The new Send To » LandXML option can be accessed by right-clicking in either the CAD or 
Paper Window. The resulting XML file is saved under the data folder of your current project. 

 

The Add Metadata check box has been added to the AutoCAD DXF/DWG node of the Import Design 
Data form. 
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When the Add Metadata check box is selected, elements imported into MineScape will include two 
additional metadata fields under the Metadata section of the Properties tab - Autocad Name and 
Autocad Layer. 

• Autocad Name - The file path for the AutoCAD DXF/DWG file. 

• Autocad Layer - The original layer name from the AutoCAD DXF/DWG file. 

 

Note: The output design file must use the extended design file format in order to apply metadata tags to 
the imported elements. Selecting the Add Metadata check box will increase the time needed to complete 
the import as metadata tags need to be assigned to each element imported. 

The Export a Design File to a DXF File and Export a Design File to a DWG File forms have been updated 
to include the ability to customise the names of the output AutoCAD layers. 

 

Select the Use MineScape Layer Name check box to use the MineScape layer name(s) when naming the 
resulting AutoCAD layer(s). Clear the Use MineScape Layer Name check box to assign custom names to 
the resulting AutoCAD layers. In the following example, the custom layer name of 'New_Line' is assigned 
to the output AutoCAD layer. 
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The Export a Design File to a DXF File and Export a Design File to a DWG File forms are displayed after 
using the right-click Save As » DXF/DWG option on selected layer in a design file. 

 

The Save As option can be accessed by right-clicking on highlighted layers through the Explorer tab or 
by right-clicking on highlighted references through the Display tab. 



 Release Notes 

 

80 
 

Geology 

Improved StratModel Forms 
The appearance and layout of numerous forms have been upgraded and improved to provide a better 
user experience. 

 

Block Model Enhancements 
The Reserves to XPAC and Polygons to XPAC options have been added to the Data Exchange » Export 
group of the Output ribbon. 

 

• Reserves to XPAC - Create a CSV file containing reserving numbers suitable for import into 
XPAC. 
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• Polygons to XPAC - Create a CSV file containing reserving polygons suitable for import into 
XPAC. 

 

Improved GDB Forms 
The appearance and layout of numerous forms have been upgraded and improved to provide a better 
user experience. 
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Surface Engineering 

Open Cut Enhancements 
The Walkroute Grade Check option has been added to the Graphics section of the Open Cut ribbon. 

 

 

The Walkroute Grade Check option can be used to create station numbers on a selected element. The 
stations numbers are created using a specific distance interval and a slope percentage is generated 
between the station numbers (segmented). The station numbers are created as text elements and saved 
into the current design file. 
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The Export to Tempo option has been added to the Mining Solids group of the Strip Planning ribbon. 

 

 

The Export to Tempo option can be used to export mining block layers and reserve table files to table 
files that can be used by Minemax Tempo. 
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Updated Settings 

Default Editor for Microsoft Excel Files 

The Default Editor section has been added to the Miscellaneous node of the Options form. This new 
section can be used to configure the default editor to use when opening Microsoft Excel spreadsheet 
files. Spreadsheet files can either be loaded through the Spreadsheet Editor (the default) or Microsoft 
Excel. 

 

Once the default editor has been set, the  or  button is available within applicable Report File and 

Excel File fields on displayed forms. Click the  button to open a spreadsheet file through the 

Spreadsheet Editor. Click the   button to open the spreadsheet file through Microsoft Excel. 

 

The Options form can be accessed through File » Options or by clicking the  icon on the System 
toolbar. 
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Hide Markers on Vertices 

The Hide Markers on Point Elements check box has been renamed to Hide Markers on Vertices. The 
check box is displayed on the Performance node of the Graphics Settings form. 

 

The Graphic Settings form can be accessed through clicking the  icon from the Graphics group of the 
Home ribbon. 
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Expiring Licenses 
Warnings for an expiring license are now colour coded. Warnings are displayed through the Start Page 
and the bottom right corner of MineScape. 

 

 

The yellow Maintenance Expired warning message indicates that MineScape will continue to work, 
however, certain apps may not be able to auto-update. For example, if the CAD app is affected, the 
message will indicate that auto-updates will be disabled. If an app other than CAD is affected, the 
message will indicate that the app will cease to work if any updates are installed. The Maintenance 
Expired warning message is applicable to the Permanent license type. 

The red License Expiring warning message will indicate that MineScape will stop working once the 
expiry date is reached. The License Expiring warning message is applicable to the Temporary, Expiring 
and Subscription-based license types. 

Note:. In the event that both Permanent and Expiring types are present in the licence file, the Expiring 
licence types take precedence. 

The Remind Me Later and Dismiss options are available through the list control on the displayed 
warning message. 

 

• Remind Me Later - Hide the warning message for two days, at which point it will be displayed 
again. 

• Dismiss - Hide the warning message for 30 days. 
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Microsoft Windows 11 Support 
MineScape 2021 now supports Microsoft Windows 11. 
 

Custom App Upgrades 
Due to backend changes implemented during the development of MineScape 2021 Update 3, existing 
custom app installations need to be removed and reinstalled using updated installers. The latest custom 
app installers can be downloaded directly from the MineScape software distribution portal. 
 

Defects 

#32981 - Able to access content menu through read-only field 

Problem: Able to access the right-click context menu through the Grid Spec field on the Interval 
Intersection form. Field is read-only and context menu should not be accessible. 

#33305 - RapidCAD purple dot icon changing position 

Problem: RapidCAD's purple dot icon changing position when modifying the rotation point. 

#33498 - Invalid mesh file created 

Problem: An invalid mesh file is created when importing multiple mesh files while the Generate 
Individual Files check box is cleared. 

#33512 - Error when downgrading design file 

Problem: An error occurs when attempting to downgrade a design file that does not contain a layer. 

#34324 - Unable to locate duplicate points 

Problem: Unable to locate and delete duplicate points using Repair Data » Remove Duplicate Points on 
the Design ribbon. 

#34420 - Exception error displayed on start-up 

Problem: An exception error is displayed when starting up MineScape. 

#34443 - Feature articles and news lists are truncated 

Problem: The Feature Articles and News list are truncated when using high display resolutions and DPI 
(dots per inch) settings. 

#34591 - Height cue visual override not working 

Problem: The Out of Bounds Data option is not working as expected when using the Height Cue visual 
override. Data displayed using the Shadow option even when using another available option. 

#34603 - Unable to retrieve column names 

Problem: Unable to retrieve column names through Setup » Quality Parameters on the Quality ribbon. 

#34607 - Incorrect build SQL statement 

Problem: Incorrect build SQL statement. 
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#34640 - Unable to open notification 

Problem: Unable to open and view MineScape notification. 

#34720 - Unable to view list of formspecs in subfolder 

Problem: Unable to view list of formspecs in subfolder. 

#34747 - Hidden elements visible after editing 

Problem: Previously hidden elements is visible after editing an element. 

#34778 - Display definition missing 

Problem: Display Definition column missing from Geological Model » Contour on the StratModel ribbon. 

#34800 - Dragging image does not highlight selected polygon 

Problem: Dragging an image into the CAD window does not highlight the selected polygon. 

#34842 - Hollow fill behaving incorrectly for grids 

Problem: Hollow fill visual override behaving incorrectly for grids. 

#34849 - Unable to use bottom northing and bottom easting 

Problem: Unable to use bottom northing and bottom easting when importing quality data. 

#34850 - Unable to merge resource classification polygon 

Problem: Unable to merge polygons of influence when using horizontal calculation. 

#34866 - Design file to DXF/DWG origin issue 

Problem: Design file to DXF/DWG origin issue. Results don't match MineScape CAD. 

#34895 - Warning message displayed after clicking OK 

Problem: Warning message displayed after clicking OK on the output report file name. 

#35101 - Unable to draw element to layer 

Problem: Unable to draw element after layer opened through Short Range Planning form. 

#35133 - Error appears when saving drill hole 

Problem: An error appears when saving a drill hole through Drill Hole Edit form. 

#35177 - Unable to use colour selection dialog 

Problem: Unable to select a colour from the colour selection dialog on the Contour form. 
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MineScape Help 

Help » Help Location » Offline 
A new MineScape 2021 offline help installer has been uploaded to the MineScape software distribution 
portal. An existing MineScape 2021 help installation must be removed prior to installing the updated 
MineScape 2021 help. 
 

Help » Help Location » Online 
Content stored on the official MineScape help server is updated automatically to reflect the changes 
introduced through MineScape 2021 Update 3. 


